Version haut débit de: Forum du site Lebrikabrak
Aide - Rechercher - Membres

Codage des menus (accents)

Cesar (26 Novembre 2009, 11:08)
J'ai mis en place récemment le "plugin" GetFileHtml
cela fonctionne
les pages html s'affichent bien
mais tous mes menus s'affichent avec des codes bizarres

comme : T�l�chargement

quand je clique sur un autre menu tout redevient normal
comment paramétrer pour éviter ce problème d'affichage

César
jchouix (27 Novembre 2009, 23:00)
bonsoir,
c'est un problème de codage des caractères par rapport au charset de la page.
As tu une adresse pour voir ?
Merci.
Cesar (28 Novembre 2009, 17:16)
oui c'est le site d'une association :

www.avenir-langue-francaise.fr

(si je teste en local il n'y a pas ce problème)

merci
jchouix (28 Novembre 2009, 22:23)
bonsoir,
je viens d'aller voir et c'est bien un problème d'encodage des caractères de ta page.
Avec quel éditeur as tu créé ta page html ?
Vérifies que le codage de ta page est bien iso-8859-1 (europe de l'ouest) et pas utf-8 comme c'est le cas actuellement.
A+
Cesar (30 Novembre 2009, 0:27)
Je ne comprends pas je n'ai mis que 3 pages html
accessibles avec le menu du haut (Pages)

et quand j'affiche le code source il y a bien pour les 3 la ligne :

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

je les ai écrites avec Dreamweaver CS3

merci pour ta réponse

M.A.R.
jchouix (30 Novembre 2009, 19:40)
bonsoir,
Citation
je les ai écrites avec Dreamweaver CS3

Tu ouvres ta page dans Dreamweaver CS3 et tu vas dans le menu "modifier" puis "propriétés de la page". Ensuite, tu sélectionnes dans la fenetre l'item "Titre/codage" à gauche et ensuite, à droite, dans le champ déroulant intitulé "codage" tu sélectionnes l'option "Europe centrale (ISO)".
Tu appliques les modifs et enfin, tu enregistres ta page.
Le codage de ta page correspondra ainsi à l'encodage iso de guppy et n'induira pas en erreur le navigateur pour son affichage.
A+
Cesar (30 Novembre 2009, 22:26)
bonsoir,

j'ai changé le codage des 3 pages (europe centrale iso = <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2" />)

hélas aucun changements...

dès que je charge ces pages les accents s'affichent avec des caractères bizarres


dès que je reviens à l'accueil cela redevient normal

je ne comprends pas ...

merci

MAR
Cesar (02 Décembre 2009, 13:14)
pour compléter mon message précédent
Citation
bonsoir,
j'ai changé le codage des 3 pages (europe centrale iso = <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2"/>)
hélas aucun changements...
dès que je charge ces pages les accents s'affichent avec des caractères bizarres
dès que je reviens à l'accueil cela redevient normal
je ne comprends pas ...
merci
MAR

quand je demande l'affichage du code source de ma page d'accueil
il y a le code :
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
et non
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2" />

où cela se règle-t-il dans guppy ?

merci MAR
jchouix (02 Décembre 2009, 15:02)
bonjour Cesar,
je pense que tu n'as pas compris ce que je te demandais de faire.
Tu as modifié la déclaration du charset de ta page mais tu n'as pas changé l'encodage de ta page d'où le fait que le problème est toujours présent.
Dis autrement, ce n'est pas parce que tu mets <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2"/> dans l'entête de ta page que tes caractères sont encodés en iso-8859-2.
Le problème concernant tes fichiers,c'est qu'ils sont encodés en UTF-8 (enfin, je pense) ce qui n'est pas bon car il faut qu'ils soit encodés en iso-8859-1.
J'espère avoir été plus clair cette fois.
A+
Cesar (02 Décembre 2009, 22:23)
Non j'avais bien compris et dans Dreamweaver (en fait j'ai Dreamweaver 8 et pas CS3 mais cela ne doit rien changer)
j'ai bien fait modifier" puis propriétés de la page et Titre/codage et dans le champ déroulant intitulé codage j'ai sélectionné Europe centrale (ISO)

Mais hélas cela n'a rien changé... (est-ce que le Titre/Codage joue un rôle : XHTML 1.0 strict ou HTML 4.01 strict ... ?

j'avais simplement été voir le résultat dans le code

merci si tu as une idée

César
jchouix (02 Décembre 2009, 23:59)
re-,
peux tu m'envoyer par mail tes fichiers html pour que je jette un coup d'oeil.
Merci
A+